Hello and welcome to our community! Is this your first visit?
Register
Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1. #1
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default Knocking from suspension - strut top mounts?

    Viewing Content Requires Registration

    Viewing Content Requires Registration

    Had a knocking / creaking from front end for a little while at low speed especially but also going up bumps generally or uneaven ground.

    Changed droplinks which improved things but the main knock was still there.

    Checked wishbones which seem fine as do engine mounts although not checked gearbox one but no excessive movement of lump.

    However when rocking the car side to side the metal disc in the top mount visibly moves around! Is this normal.... Am wondering if the top mounts are shot as opposed to gearbox mount.

    Any clues? Also suspension on pass side feels like its ****ed when you hit bumps hard even drain covers but low speed it behaves drivers side feels normal.

    Knock is definitely pass side but creaks right across front end.
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  2. #2
    Mia's Bitch R242_GBU's Avatar
    Join Date
    Mar 2010
    Location
    Birmingham
    Posts
    4,478
    Rep Power
    500

    Default

    To be fair, ive never actually worked with top mounts.

    But knowing 306s, id look at drop links and bottom arm bushes. Normally the rear one that bolts over the subframe. Worth checking before you fork out any cash.

  3. #3
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Done the droplinks will have a look at the rear bushes last check they looked ok but no harm in another look
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  4. #4
    Call me "Wendy Halfsack" Parksy87's Avatar
    Join Date
    Apr 2012
    Location
    Birmingham
    Posts
    5,032
    Rep Power
    85

    Default

    Iv a creak knock and bang on mine that has been there for months despite practically all of the front suspension being changed :/ even powerflexed bottom arms :/ arb bushes seem to be the only thing i haven't touched

  5. #5
    Long Term Member gareth7's Avatar
    Join Date
    Jun 2009
    Location
    down a load of bumpy lanes out in the sticks
    Posts
    6,065
    Rep Power
    101

    Default

    If it's a top mount bearing a good indicator is when you're turning the wheel at parking/pulling away speeds......they always knock slightly. Since lowering mine just under 3 years ago I've got through three sets of the damn things........even the dearer Lemforder ones only lasted about 9 months.

    As R242_GBU said, check your P bushes at the rear of the wishbones first as you can easily see if these need doing.

    I'd say with the movement you can see in the disc in the top mount it's pretty likely the bearings in there are shot......
    Custom badges/gauge pods, other custom exterior/interior trim and masked Valeo crystal headlights contact me for details or click on the link below

  6. #6
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Sounds about right that and in the pics you can see the gap between metal amd rubber.
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  7. #7
    Jedi Master Warlord's Avatar
    Join Date
    Jun 2008
    Location
    Coventry, CV6
    Posts
    18,924
    Rep Power
    500

    Default

    Iv a creak knock and bang on mine that has been there for months despite practically all of the front suspension being changed :/ even powerflexed bottom arms :/ arb bushes seem to be the only thing i haven't touched
    Doubtful it would be arb bushes. I don't know of one case where they have worn out and needed replacing. No one seems to do any after market ones either.

  8. #8
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Will have a look at the p bushes. Might change them anyway for some vibra technics ones been tempted to uprate them for a while same as powerflex fronts might start with the p bushes and see how they feel.
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  9. #9
    Long Term Member gareth7's Avatar
    Join Date
    Jun 2009
    Location
    down a load of bumpy lanes out in the sticks
    Posts
    6,065
    Rep Power
    101

    Default

    My money's still on your top mounts mate.......

    I recently stripped down a set of faulty coil overs for a member on here to find out what was causing the knocking sound they were creating. The top mount bearing were only a few months old at the most and both sides had failed. When you rotated them in your hand they felt gritty and notchy when they were being turned.......always a bad sign even if they look ok on the outside.

    This wasn't the only issue with the coil overs unfortunately, one of the shock units was blown too.
    Custom badges/gauge pods, other custom exterior/interior trim and masked Valeo crystal headlights contact me for details or click on the link below

  10. #10
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    I checked the p bushes they look ok was hoping it might be them as easier fix than the top mounts.

    I'm not 100% comfortable with the coil spring compression part but guess due to lack of funds its time to bite the bullet.

    Is there any other routine maint i can do while they are stripped down?
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  11. #11
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Right ive ordered a set of kyb replacement mount kits and 2 neilsen coil spring compressors with jaws that wrap over the springs and grip in 2 places per jaw, should be nice and safe.
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  12. #12
    Member flymo's Avatar
    Join Date
    Jan 2010
    Location
    London, United Kingdom, United Kingdom
    Posts
    224
    Rep Power
    7

    Default

    just checking, should there not be any gap between the mounting plate and the rubber (as in the first picture)?

    also, I had it jacked up, and tried to turn the front wheels by hand (like steering them), they were pretty stiff to rotate, is that normal? there were also some clunks and 'boings' as well... any ideas?

    top mounts are only a few months old, but I think the guys that did them may have f**ked them somehow...?

  13. #13
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Put it this way the new ones have no gap at all and i mean none. Wheels will be stiff if turning with engine off as no power assist
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  14. #14
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    As you can see the two parts are bonded together
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  15. #15
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  16. #16
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Clunks and boings could be arb related but more likely mounts

    have you checked for play in the wishbone bushes? Bushes are better checked with ball joint disconected from hub as front setup is pretty tight. So if not totally mashed you might not feel the play with all connected
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  17. #17
    Paid Member
    Join Date
    Aug 2013
    Location
    Newry
    Posts
    58
    Rep Power
    1

    Default

    I have the same knocking noise whenever I steer lock full left or right. Would it be the top mounts causing the problem?

  18. #18
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    It could be. Pop the bonnet and bounce front end. You will soon see if seperated from the movement of the metal plate.

    Is it knocking on full lock when pulling off and reversing or dry steering? Wouleld be wise to check wishbone bushes first to rule them out. This is easier with ball joint disconnected from hub
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  19. #19
    Member kpsmithuk's Avatar
    Join Date
    Oct 2007
    Location
    Maidstone, United Kingdom, United Kingdom
    Posts
    570
    Rep Power
    17

    Default

    Strut mounts were shot had to replace gearbox mount as well. Thats in addition to the drop links that were on there way!
    Viewing Content Requires Registration
    2.0 Hdi LX - Stage 1 Re-Map - K&N 57i - Custom Intake [WIP]

  20. #20
    Call me "Wendy Halfsack" Parksy87's Avatar
    Join Date
    Apr 2012
    Location
    Birmingham
    Posts
    5,032
    Rep Power
    85

    Default

    Strut mounts were shot had to replace gearbox mount as well. Thats in addition to the drop links that were on there way!
    All sorted?


 

Similar Threads

  1. Help me find Strut top mounts please
    By ginge191 in forum Chassis/Brakes/Suspension & wheels
    Replies: 15
    Last Post: 08-11-2011, 04:52 PM
  2. Question: Strut-top Mounts '99 Vplate gti6
    By Ed Doe in forum Chassis/Brakes/Suspension & wheels
    Replies: 13
    Last Post: 18-08-2011, 07:09 AM
  3. strut top mount kit.
    By pat73 in forum Chassis/Brakes/Suspension & wheels
    Replies: 4
    Last Post: 18-08-2009, 06:53 PM
  4. suspension top mount bearing
    By marksdturbo in forum Chassis/Brakes/Suspension & wheels
    Replies: 7
    Last Post: 06-08-2009, 07:04 PM
  5. knocking from suspension
    By ste_buzz in forum General 306 questions & answers [Archives]
    Replies: 6
    Last Post: 30-11-2007, 01:00 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •